Issue
When attempting to upload a submission within the application, the Upload Submissions dialog box either does not appear or flashes momentarily before disappearing.
Affected versions
v30 and later
Affected configurations
All configurations
Cause
If the user trying to access this feature does not have sufficient permissions, they will not be able to access this feature.
In v30, Flows were introduced. When uploading submissions, there is an option in this dialog to select the flow the submission should be sent to. If the user does not have the View Flows permission, the dialog box does not load.
In v31 and later, Cases were introduced. Similarly, the dialog has an option to select a case you want to assign the submission to. If the user does not have the View Cases permission, the dialog box does not load.
Solution / Workaround
Users need to be assigned appropriate permissions to access the Create Submission feature within the application.
In v30, users need a minimum of Create Submissions, View Submissions, and View Flows permissions assigned in their permission group.
In v31 and later, users need a minimum of Create Submissions, View Submissions, View Flows, and View Cases permissions assigned in their permission group.